Centos 7 安装PHP5.5 5.6 7.2

安装和启用EPELRemi存储库

yum update
yum upgrade

yum install epel-release
rpm -ivh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm

接下来,安装yum-utils,它是与yum集成的各种实用程序,以增强其默认功能,为其提供更高级的包管理选项,并使其更易于使用。它的一些重要功能包括操作存储库,在运行中启用或禁用包等,而无需任何手动配置。

yum install yum-utils

yum-utils提供的最重要的程序之一是yum-config-manager,您可以使用它来激活Remi存储库作为安装各种PHP版本的默认存储库。例如,如果要在CentOS 7上安装PHP 5.5PHP 5.6PHP 7.2,只需启用它并如图所示进行安装(以下命令三选一)。

yum-config-manager --enable remi-php55 [ 安装PHP 5.5 ] 
yum-config-manager --enable remi-php56 [ 安装PHP 5.6 ]
yum-config-manager --enable remi-php72 [ 安装PHP 7.2 ]

在启用了PHP的选定版本后,您就可以安装PHP(这里,我们选择安装PHP 5.6)以及所有需要的模块了,如下所示

yum install php php-mcrypt php-cli php-gd php-curl php-mysql php-ldap php-zip php-fileinfo php-mbstring php-common php-pdo php-devel php-fpm

需要注意的重要事项:如果您出于某种原因想要降级PHP版本,则需要删除现有的PHP版本,然后使用所需的模块重新安装新的PHP。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据